剛剛在更新Rubygems與Rails 2.0
Rubygems安裝好了,可是Rails 2.0裝不起來
錯誤訊息(只貼關鍵)
Rails 2.0 SSL is not installed on this system
OK... 該怎辦呢?
先說明一下我的系統環境:
  • Ubuntu (版本不拘)
  • Ruby 1.8 (自己Compile的)
  • RubyGems 0.9.5 (嗯,剛剛更新好的)
我之前好像有記錄過透過apt-get安裝與自己編譯的ruby,兩種的預設目錄都不一樣
apt-get安裝的預設目錄是
/usr/lib/ruby
自己編譯的則是在
/usr/local/lib/ruby
差別就在這邊了
所以我們可以用網路上所教的方式來解決,並且動點手腳來完成
sudo apt-get install libopenssl-ruby1.8
cp -r /usr/lib/ruby/1.8/openssl* /usr/local/lib/ruby/1.8/
cp /usr/lib/ruby/1.8/i486-linux/openssl.so /usr/local/lib/ruby/1.8/i686-linux
這樣就可以更新了!
創作者介紹

卐只有兩面的盒子卍

hechian 發表在 痞客邦 PIXNET 留言(0) 人氣()